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1 License agreement 
All computer programs (hereinafter collectively referred to as the 'Software') are downloadable from 

the webpage https://github.com/stebond/TOUGH2ViewerX and can be used only under the Apache 

License, Version 2.0 (https://opensource.org/licenses/Apache-2.0). 

2 Introduction 
TOUGH2Viewer is a Java program capable of displaying structured and unstructured (Voronoi 

complying) grids, and structured grids compliant with the TOUGH2 family of codes (Pruess et al. 

1999).  

In particular, TOUGH2Viewer allows the navigation through a 3D grid compatible with the 

TOUGH2 data file format and visualize: 

 the thermodynamic variables and the material (namely, petrophysical properties) of each 

block; 

 maps of isovalues (2D) of all thermodynamic variables; 

 isosurfaces (3D) of all thermodynamic variables; 

 flows of mass and heat between blocks; 

 spatial profiles of thermodynamic variables along Cartesian direction; 

 time plot of thermodynamic variables of a selected block. 

All commands to manage a 3D visualization (zooming, pan, rotations) are CAD complying. 

In the following chapters, four tutorial examples will be presented: 

1. structured 2D grid generated with MESHMAKER. 

2. structured 3D grid generated with MESHMAKER. 

3. unstructured 3D (2.5D) grid generated with AMESH (). 

4. Fully unstructured 3D grid generated using VORO2MESH (Bonduà et. al, 2017) 

All the example cases reported in this tutorial are simulation results obtained using the module 

EWASG (Battistelli et al., 1997) as implemented in iTOUGH2 (Pruess, 1999). 

Related publications can be found in Bonduà et al. (2012, 2017), Berry et al. (2014). 

 

https://opensource.org/licenses/Apache-2.0
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3 System Requirements 
The minimum system requirements to use TOUGH2Viewer are: 

1GB of RAM; 

100 MB of free disk space; 

Graphic card equipped with 512 MB RAM; 

Supported OS: Linux Ubuntu 8.04 or later, Windows XP, Vista, 7, 8 10. 

TOUGH2Viewer requires Java™ Runtime Environment (JRE) version 1.6.14 (or later) and the 

Java extension to display three dimensional graphics (Java3D) version 1.5.1 (or later) to be already 

installed on the system. To download installers and instruction manuals, please visit the official 

Oracle Web Site. 

 

3.1 Windows Java3D installation troubleshot 

Sometimes, the Java3D installation package cannot install properly the Java3D runtime libraries. 

Also, when the JRE is updated to a new version, the Java3D package will stop to work. It is possible 

to fix this issue by following the below procedure. 

Run the Windows File Manager and locate the java folder. Usually, in the English version, it will be 

in the “C:\Program Files\Java” folder as showed Figure 1. 

 

Figure 1 – Java folder. 

Note: if you install the JRE 32 bit version, you will find the Java folder located at “C:\Program Files 

(x86)\Java”. Therefore, in the following instructions you should use this path. 

Copy the file “j3dcore-ogl.dll” from the folder “C:\Program Files\Java\Java3D\1.5.2\bin\” (Figure 2) 

and paste it in the folder “C:\Program Files\Java\jre7\bin”. 

 

 

Figure 2 – j3dcore-ogl.dll location. 
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Copy the files j3dcore.jar, j3dutil.jar and vecmath.jar from the folder  

“C:\Program Files\Java\Java3D\1.5.2\lib\ext” (Fig. 3), and paste them in  the folder 

 “C:\Program Files\Java\jre7\lib\ext”  

 

Fig. 3 – j3dcore.jar, j3dutil.jar and vecmath.jar folder. 

 

If you have more than one java installation folder, e.g. jdk1.6.x.y etc., repeat steps from “a” to “d” 

for each folder. 
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4 Installation, execution and uninstallation instruction 

4.1 TOUGH2Viewer installation 

To install TOUGH2Viewer, user simply has to copy into a folder and unzip the compressed file 

(TOUGH2Viewer_v.X.zip where X indicates the version) containing the whole software programs 

and examples. The unpacked package of files consists of two subdirectories, dist (standing for 

distribution) and ExampleData. In the examples described in this manual, the supposed folder will 

be “D:\T2Viewer\”. So, at the end of the installation one should have a directory structure like the 

following: 

 
D:\T2VIEWER 

  
\---dist 
    |   go.bat 
    |   go1024.bat 
    |   go1540.bat 
    |   go2048.bat 
    |   go3072.bat 
    |   go4096.bat 
    |   go6144.bat 
    |   image.png 
    |   iTough2Viewer.ini 
    |   License.txt 
    |   LogFile.txt 
    |   path.ini 
    |   README.TXT 
    |   shape.ini 
    |   splash.jpg 
    |   tough2viewer.ini 
    |   Tough2Viewer.jar 
    |   voro_pp.ini 
    |    
    \---lib 
            AbsoluteLayout.jar 
            commons-math3-3.6.1.jar 
            geoapi-2.3-M1.jar 
            geoapi-pending-2.3-M1.jar 
            gnujaxp.jar 
            gt-api-2.7-M4.jar 
            gt-coverage-2.7-M4.jar 
            gt-data-2.7-M4.jar 
            gt-geometry-2.7-M4.jar 
            gt-jts-wrapper-2.7-M4.jar 
            gt-main-2.7-M4.jar 
            gt-metadata-2.7-M4.jar 
            gt-referencing-2.7-M4.jar 
            gt-referencing3D-2.7-M4.jar 
            gt-render-2.7-M4.jar 
            gt-shapefile-2.7-M4.jar 
            gt-shapefile-renderer-2.7-M4.jar 
            gt-swing-2.7-M4.jar 
            iText-2.1.5.jar 
            j3dcore.jar 
            j3dutils.jar 
            jcommon-1.0.16.jar 
            jfreechart-1.0.13-experimental.jar 
            jfreechart-1.0.13-swt.jar 
            jfreechart-1.0.13.jar 
            jsr-275-1.0-beta-2.jar 
            jts-1.11.jar 
            junit.jar 
            miglayout-3.7-swing.jar 
            netcdfAll.jar 
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            servlet.jar 
            sgt-tutorial.jar 
            swtgraphics2d.jar 
            vecmath.jar 
            visad.jar 
            vtk.jar 
 
ExampleData|    
+---01_Structured_2D 
|       2D.out 
|       MESH 
|        
+---02_Structured_3D 
|       3D_F-im-w.out 
|       MESH.dat 
|        
+---03_Unstructured_3D 
|   |   3d_unstruct_03.out 
|   |   in.dat 
|   |   segmt.dat 
|   |    
|   \---Maps 
|       +---base_ss 
|       |       base_ss.dbf 
|       |       base_ss.prj 
|       |       base_ss.qix 
|       |       base_ss.shp 
|       |       base_ss.shx 
|       |       base_ss.xls 
|       |        
|       \---Raster 
|               srtm_dem 
|                
+---04_Voronoi_3D 
|       MESH 
|       tough2viewer.dat 
|       voronoi3D.out 
|        
+---05_Amiata3D 
|       01dem.dat 
|       01dem.dat.ply 
|       02fractured.dat 
|       02fractured.dat.ply 
|       03caprock_shal.dat 
|       03caprock_shal.dat.ply 
|       04shallow_res.dat 
|       04shallow_res.dat.ply 
|       05caprock_deep.dat 
|       05caprock_deep.dat.ply 
|       06bottom-5000.dat 
|       06bottom-5000.dat.ply 
|       MESH 
|       tough2viewer.dat 
|        
\---06_Structured2D 
    +---model 
    |       MESH 
    |       tough2viewer.dat 
    |       INCON.dat 
    |        
    \---Surfaces 
            00top.dat 
            00top.dat.ply 
            01top.dat 
            01top.dat.ply 
            02top.dat 
            02top.dat.ply 
            03top.dat 
            03top.dat.ply 
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4.2 TOUGH2Viewer execution 

4.2.1 Linux 

1. Navigate to the installation folder (/T2Viewer/dist/); 

2. open a terminal window in “dist” folder 

3. run the shell script, typing: 

./go.bat []  

or typing: 

java -Xmx512M -jar Tough2Viewer.jar [] 

Note that to reserve more RAM for TOUGH2Viewer execution, it is possible to use the others batch 

files allocating more MB (go1024.bat, go1540.bat, go2048.bat etc..)  

 

4.2.2 Windows 

1. Navigate to the installation folder (/T2Viewer/dist/); 

2. double click on file “go.bat” or open a DOS prompt and type: 

java -Xmx512M -jar Tough2Viewer.jar [] 

Note that to reserve more RAM for TOUGH2Viewer execution, it is possible to use the others batch 

files allocating more MB (go1024.bat, go1540.bat, go2048.bat etc..)  

 

4.3 TOUGH2Viewer uninstallation 

To remove TOUGH2Viewer, just delete the installation folder containing all the files. To obtain 

information about how to remove JRE and Java3D, please consult the JRE and Java3D manuals or 

visit the Oracle official web site. 
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5 TOUGH2Viewer overview 
TOUGH2viewer is a dialog based GUI for visualization and editing of TOUGH grids and simulation 

results. Details on the use of the menu items are reported in the chapter 6.  

The main menu of TOUGH2Viewer contains the following items (Fig. 4 (a)): 

  File: read grid and simulation results files; 

 View: grid visualization; 

 Analysis: results visualizations; 

 Tools: visualization options and editing tools; 

 ?: information about TOUGH2Viewer version. 

 

(a) (b) 

Fig. 4 – (a) TOUGH2Viewer main dialog (b) File menu items. 

 

5.1 File menu 

The File menu Fig. 4 (b) allows the reading of several TOUGH grid files in different formats. 

File menu items are: 

 

 Open structured grid: imports grid generated by MESHMAKER; 

 Open unstructured grid: imports grid generated by AMESH; 

 Open unstructured V++ grid: imports grid generated by VORO2MESH; 

 Import Surface files: Import surface files (grid type or PLY file format); 

 Import wells and Mesh Generator are still under development. 

 

5.2 View menu 

The View menu Fig. 5 allow grid and simulation results visualization. 

View menu items are: 

 

 3D Block model: 3D grid visualization; 

 3D Flow vector: 3d flow visualization; 

 3D Iso Surface: Iso Surface generation; 

 2D Contour plots: contour plot of cross section of the model 
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 2D Flow vector: flow visualization for 2D grids. 

 

 

Fig. 5 – TOUGH2Viewer View menu. 

 

All the visualization windows have a similar structure. In figure 5a it is shown that regarding the 3D 

block model visualization. 

 
Fig. 5a – TOUGH2Viewer View menu. 

 

These windows are characterized by three fundamental windows’ controls:  

- two combo-box to select the variable to be shown (“Variable” drop-down control) and the 

action to be performed on the grid model (“Action” drop-down control); 

- a slider control to move among the range of simulated time steps. 

The “Variable” drop-down control allows the user to select among the list of mutually exclusive 

variables computed in the loaded simulation file, as for example: 

-  Pressure P; 

- Temperature T; 

… .  
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The “Action” drop-down control allows the user to select among the list of mutually exclusive action 

that can be performed on the grid model showed. This list includes: 

 

- ShiftXY, ShiftXZ, ShiftYZ to split the model by block clicking; 

- ResetPositions to restore the model after the ShiftXY, ShiftXZ, ShiftYZ action; 

- Get 2D Plot to obtain a vertical, horizontal or time dependent profiles of the selected block; 

- TopView, LeftView, FrontView, RightView, BackView, BottomView, ParallelView, 

PerspectiveView, to change point of view and type of rendering; 

- setVOI to definie a Volume of Interest; 

- SnapShot: to export a image of the current view, 

- FindBlocks to select a block by name; 

- ExpandZ: to obtain a layerd view of the block; 

- QuickInfo: to obtain information about the select mouse; 

- RealTimeInfo: similar to QuickInfo, but with rollover anabled 

- SurfaceControl: to modify surface appearance; 

- Directional profile: similar to get2plot by in any horizontal direction (not just along x, y or z); 

- AutoSnapShot: serialized image saving of the current view, iterating per varibles and/or time 

steps; 

- SelectNeighbord: to activate the automatic selection of a selected blocks. By using this 

function is possible to export the selected blocks as a new MESH file; 

- MultipleSelection: to select a set of blocks; 

- ModifySelection: to change material and volume properties of the selected blocks; 

- AdvancedBlocksSelection: a set of commands to allow block selection automation. 

 

All the visualization windows (but also dialog windows) can be closed to return to the calling 

windows by clicking on the window icon  or the Close button. 

5.3 Analysis 

The Analysis menu allows plotting variables and computing statistic of the simulation results, and 

contains the following items: 

 

 Statistics: global statistics of simulation results; 

 Heat and Mass Balance: global behaviour of the variable plotted by the BALLA function of 

TOUGH as read from the simulation results; 

 Plot variables: plotting of variables with one or two range axis. 
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Fig. 6 – TOUGH2Viewer Analysis menu. 
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5.4 Tools 

The Tool menu contains the following items (Fig. 7): 

 

 Options: visualization settings and visualization options; 

 Color scale: allows the preview and file export of the colour scale; 

 Test Java3D: tests the correct Java3D installation; 

 Create INCON: allows the generation of the INCON file as specified by the user. 

 

 

Fig. 7 – TOUGH2Viewer Tools menu. 
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6 Tutorial Examples 
These tutorials are designed to introduce to the TOUGH2Viewer basic features and should take less 

than one hour to be completed at all. Once finished, the user will have the skills to explore a 3D 

simulated model, plot variables and add to the 3D model frame own maps. 

The following examples are supposed to be run under Windows operating system. 

6.1 Structured grid model 2D 

This example is related to the visualization of a 2D grid of 1800 blocks (50 along x, 1 along y and 36 

along z). The files for this tutorial can be load from the folder: 

“D:\T2Viewer\ExampleData\01_Structured_2D”. The disc letter D can change accordingly with the 

user installation. 

In particular, two files are necessary: 

 

 MESH ->the classical MESH file of TOUGH 

 2D.out->simulation results, this specific simulation was computed with the EOS EWASG. 

 

Once TOUGH2Viewer is started, then the main window of TOUGH2Viewer will be displayed, as 

shown in Fig. 8. 

 

 

Fig. 8 - The TOUGH2Viewer empty main window. 

6.1.1 Load Files 

From the main menu, select the File->Open structured grid menu item to open the "Open structured 

grid" dialog window (Fig. 9). 

  



TOUGH2Viewer Tutorial 15 

 

 

 

Fig. 9 - The “Open structured grid” dialog window. 

Click the Mesh File button to display the "Open mesh" dialog window. Browse, select and load the 

“MESH.dat” file (\T2Viewer\ExampleData\01_Structured_2D\MESH.dat). 

This operation takes few seconds.  

When loading is finished, the text box on the left side of the Mesh File button will contain the full 

path of the mesh file. 

Click the Simulated File button to display the "Open Simulation" dialog window. Locate the 

TOUGH2 simulation output file “2d.out” and select it by clicking on it. 

Then, click the Open button to start loading the file. The dialog progress bar will show the loading 

process and when it is arrived to 100 % , return to the main window clicking on the Close button. 

Now in the main window will be shown some geometric information about the loaded model (see 

Fig. 10). 

 

 

Fig. 10 - Main window with geometric information of the loaded grid. 

6.1.2 3D Block Model view 

From the main menu, click the View->3D Block Model menu item, to display the "3D Block Model" 

dialog window and to have the default 3D Model Frame view of the grid (in this specific case only 

with one block in the y coordinate), as shown in Fig. 11. The default variable showed in the dialog 

window is the first variable reported in the simulation output file (P for pressure in Fig. 4). Default 

action is ShiftXY (split the model using block clicking). 
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Fig. 11 - 3D Default representation of the Model, Top View. 

From Action combo box, select “FrontView” to change view and then the plot frame is updated as 

shown in Fig. 5. 

 

 

Fig. 12 - 3D representation of the model, FrontView. 

Close the 3D Block model dialog by clicking the window icon  or the Close button.  

For more detail on commands available for the 3D visualization management, see the example in 

chapter 6.2 and 6.3. 

6.1.3 2D Contour Plot visualization 

This functionality enables one to automatically compute and plot the contour lines of the primary 

variables. 

In the main menu, click the View->2D Contour plot menu item and the default "2D Contour plot" 

dialog window displays. From the “Variable” combo box select a variable, for example P (pressure), 

then click the Plot button (Fig. 13). 
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Fig. 13 - Pressure contour map. 

If plot’s parameters, located on the left side of the dialog, are modified, then click the Plot button to 

update the plotting. As another example, in the right part of the window of Fig. 14 it is shown the 

contour plot of the temperature variable. 

 

 

Fig. 14 - Temperature contour map 

Close the 2D Contour plot dialog by clicking the window icon  or the Close button.  

6.1.4 2D Flow Vector visualization 

This functionality gives a 2D vector representation of the flow of heat or mass among blocks. In the 

main menu of TOUGH2Viewer, click the View->2D Flow Vector menu item to display the 2D Flow 

plot dialog window (see Fig. 8). The default plot shows the first variable that is present in the 

simulation output file, and the first-time step (FHEAT in the figure). 
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Fig. 15 - Vector map of the heat flow. 

From the Variable combo box, select the VEL(LIQ.) item. Move the time slider to the last time step. 

Check the Normalize vectors check box and type 100 into Vector length text box. The 2D Flow vector 

dialog window now is as shown in Fig. 16. 

 

 

Fig. 16 - Vector map of the variable VEL(LIQ.). 

Close the 2D Flow vector dialog by clicking the window icon  or the Close button. 

6.1.5 Statistics 

In the “Statistics” dialog window is shown a table with the maximum and the minimum value for all 

the thermodynamic variables used in the simulation, and there is the possibility to plot a variable vs 

simulated time steps. 

From the menu bar, click the Analysis->Statistics menu item. The Statistics dialog window is 

displayed (Fig. 17). 
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Fig. 17 - Min and Max value for simulation data. The default plot is first variable vs time. 

To change the time steps, use the "Time" combo box. To change the plotted variable, use the 

“Variable” combo box. 

Close the Statistic dialog by clicking the window icon  or the Close button. 

Exit from TOUGH2Viewer by clicking the window icon  or by the main menu item File->Exit. 
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6.2 Structured 3D Grid model 

This example manages a 3D structured grid representing a spatial domain of 5000x5000x3600 m3 

discretized in 101036 blocks.  

The files used in this example are 

 MESH.dat -> the classical MESH file of TOUGH 

 3D_F-im-w.out -> simulation results of a numerical model computed using EWASG. 

 both recorded in the folder “\T2Viewer\ExampleData\02_Structured_3D”. 

The simulation results contain two time steps. 

Start TOUGH2Viewer (under Windows OS) by double clicking the go.bat batch file. 

6.2.1 Load Files 

From the TOUGH2Viewer main menu, click the File->Open structured grid menu item, and then 

the "Open structured grid" is displayed (see Fig. 18). 

 

 

Fig. 18 - Open Structured grid dialog. 

Click the Mesh File button to display the Open mesh dialog window and load the “MESH.dat”. Click 

the Open button to start loading the file. When loading is finished, the text box on the left side of the 

Mesh File button will contain the full path of the mesh file. 

Click the Simulated File button, and then the Open Simulated dialog window is displayed. Select 

the “3D_F-im-w.out” file and click the Open button to load it. The progress bar of the dialog will 

show the loading advancement. 

When the reading is complete, progress bar a 100%, close the dialog by clicking Close button. Then, 

in the main window are shown some geometric information about the model. 

6.2.2 Export Structured Data to Paraview1 

Exporting the MESH and the simulation results to Paraview is quite simple using TOUGH2Viewer. 

After loading the MESH file and the simulation results, click the button 

ExportTOUGH2Viewer.dat. A file named tough2viewer.dat is created in same working folder. 

Close TOUGH2Viewer and re-start a new session of TOUGH2Viewer. Now choose from the menu 

the command File->Open unstructured V++ grid … . Using buttons, load the tough2viewer.dat 

file, the MESH and the simulation results. Click the Export2VTU button. A set of out_[i].vtu files is 

generated in the working folder. You can now open these files with Paraview. See also the chapter 

6.4.4 for details. 

                                                 
1 http://www.paraview.org. 
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Fig. 19 - Open unstructured V++ grid dialog window. 

 

6.2.3 3D block model view 

From the main menu, click View -> 3D block model menu item. The "3D Block model" dialog 

window is displayed with the default setting, as shown in Fig. 20. 
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Fig. 20 - 3D Block model window, top view. 

From the “Variable” combo box, select the T variable (Temperature). Move the time slider in position 

2. Rotate both the model and the color scale using the mouse pointer. 

The plot of “3D Block model” dialog window, will be similar to that show in Fig. 21. 

 

 
 

Fig. 21 - 3D Block model box showing the Temperature variable at the time step 2. 

To split the 3D model Frame, from the “Action” combo box select the ShiftXY command, move the 

mouse on the 3D model frame and left click over a block. The upper part of the model above the 

clicked block will be shifted as shown in Fig. 22. 
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Fig. 22 - 3D modelFrame horizontally sectioned. 

From the Action combo box, choose ResetPositions command to reassembly the 3D model Frame, 

and then select the command Action->Get2Plot. Move the mouse on the 3D frame plot and left click 

on a block to select it. 

A Profiles dialog window is displayed, as showed in Fig. 23 and Fig. 24. One can select another 

variable to plot, acting on the “Variable” combo box, or change the time step by moving the time step 

slide bar. The “Domain” combo box allows to create a scatter plot of the chose variable, versus one 

of the Cartesian directions (x, y or z) or versus time. 

 

 

Fig. 23 – Graph of the pressure versus the x coordinate. 
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Fig. 24 – Graph of the pressure versus the z coordinate. 

For structured grids, is possible to have the background of the plot coloured by the rocktype color 

scale. Click in option box Background Material to obtain the plot as shown in Fig. 25. In order to 

modify the rocktype scale, open the Option dialog window (accessing it from Tools->Options->tab 

3D Model object). 

 

Fig. 25 – Graph of the pressure versus the z coordinate, with background coloring. 

Close the Profiles dialog window by clicking the window icon  or the Close button. 

Select the Action->ExpandZ command to explode the 3D Model Frame of the all layers (see Fig. 

26). 
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Fig. 26 - ExpandZ command result. 

Select both Action->ResetPositions and then Action->QuickInfo commands. Then click on a block 

to automatically obtain information about it reported at the bottom of the “3D Block model” dialog 

window (see Fig. 27). 
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Fig. 27 - QuickInfo command result, information are printed in a panel at the bottom of the window. 

Select the Action->SetVOI command to set the coordinates of a volume of interest. When the 

SetVOI dialog window is displayed, select the "Enable" check box, click the Default button to set a 

default volume to be hidden (it will be hidden a volume corresponding to half dimension on the three 

Cartesian direction) and click the Apply Hide VOI button. The 3D Block model is modified as shown 

in Fig. 28. 

 

 

Fig. 28 - SetVOI function applied to the model. 

From the Block appearance combo box, select RockTypes. The block scale colour is related to the 

rock type (as shown in Fig. 29). 
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Fig. 29 - 3D Block model in material color scale. 

Note that the color scale frame on the right is not updated with rock type colors. The legend of rock 

type color is visible in a table present in the Option dialog window. From the main menu select Tools-

>Option to display the Option dialog window and click 3D Block model object tab. To send to the 

printer the rock type color scale, click the Print button.  

Close the 3D Block model and the Option dialog by clicking the window icon  or the Close 

button. 

6.2.4 3D Flow Vector visualization 

This functionality gives a 3D vector representation of the heat or mass exchange among blocks.  

From main menu, click View->3D Flow Vector and the 3D Flow vector dialog window is displayed 

as shown in Fig. 30. 

 

 

Fig. 30 - Vector representation of the heat flow. 

From the Selection variable combo box select FHEAT. Move the time slider to “2” and manage the 

model with usual CAD command. 

From the Action combo box, select Get 2D Plot command, then click a vector on the 3D model and 

then the default Vertical Flow Profiles dialog window is displayed (see Fig. 31). 
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Fig. 31 - Vertical heat flow profile. 

From Block combo box, is possible to change the block to be used. 

From Variable combo box, select a different flow variable and from the Domain combo box choose 

z (versus z axis) or t (versus time) 

Close the Vertical Flow Profile dialog by clicking the window icon  or the Close button. 

Close the 3D Flow vector dialog by clicking the window icon  or the Close button. 

6.2.5 3D Iso Surface 

From TOUGH2Viewer menu bar, click View->3D IsoSurface (that is the three-dimensional 

analogue of the isolines), and then a 3D IsoSurface dialog window is displayed as shown in Fig. 32. 

 

 

Fig. 32 - 3D IsoSurface dialog. 

Click Plot iso surface button to obtain an IsoSurface dialog (see Fig. 33). 
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Fig. 33 - IsoSurface Dialog for pressure and time step 0.  

In the IsoSurface dialog (the base is the minimum value of the selected variable), rotate the model 

from top view with usual CAD commands. Move the slide bar to set an iso value or move the time 

step slide bar and observe surface modification. An example is shown in Fig. 34. 
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Fig. 34 - Dialog window for the pressure IsoSurface. 

Close the IsoSurface for... dialog by clicking the window icon  or the Close button. 

Close the 3D Iso Surface dialog by clicking the window icon  or the Close button. 

6.2.6 2D Contour Plot visualization 

This functionality enables to plot the primary variables by means of contour lines. 

From main menu, click View->2D Contour plot. A Contour Plot dialog is displayed. From the 

Variable combo box, choose P (Pressure), move the slide bar to 2, select the “XZ” item from 

Sectioning Plane combo box. In the y= text box, type 500 (to specify the y coordinate of the 

sectioning plane). Click the Plot button and the Contour Plot dialog is updated as shown in Fig. 35. 
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Fig. 35 - 2D Contour Plot for the Pressure (Pa). 

Close the Contour Plot dialog by clicking the window icon  or the Close button. 

To get basic statistic information about the simulated data, from main menu, click Analysis-

>Statistics menu item and then the “Statistics” dialog window is displayed (see pag. 18). 

Exit form TOUGH2Viewer by clicking the window icon  or by File->Exit menu item. 

6.3 Unstructured 3D grid model 

This tutorial example is related to an unstructured grid model, built using a special GIS GRASS 

version (Berry et al, 2014) adapted to create locally refined grids. 

Please visit http://software.dicam.unibo./tough2gis web pages for further detail. 

The example folder “\T2Viewer\ExampleData\03_Unstructured_3D” contains the following files and 

subfolders: 

 3d_unstruct_03.out: simulation results 

 in.dat: the input file for AMESH 

 segmt.dat: output file of AMESH 

 

Subfolder Maps: 

 Subfolder \”base_ss” contains the 3D iso contour of the temperature: 

o base_ss.dbf 

o base_ss.prj 

o base_ss.qix 

o base_ss.shp 

o base_ss.shx 

o base_ss.xls 

 Subfolder Raster 

 Subfolder “\srtm_dem” contains gridded ASCII files of the digital elevation model of the 

topography. 

 

Start TOUGH2Viewer (Windows OS) by double clicking the batch file go.bat then the main window 

of TOUGH2Viewer is displayed, as shown in Fig. 36. 

 

http://software.dicam.unibo./tough2gis
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Fig. 36 - TOUGH2Viewer empty main window 

6.3.1 Load Files 

From main menu, click the File->Open unstructured grid menu item.  

The Open unstructured grid dialog window will be displayed (Fig. 37). 

 

 

Fig. 37 - Open unstructured grid dialog window 

Click the In File button to open the Open In dialog window and select the file called “in.dat”. 

Click Open to start reading this file. Once finished the text box on the left side contains the full path 

of the file. 

Click the Segmt File button to open the Open Segmt dialog window and select the “segmt.dat” file. 

Click Open to start loading this file. When the loading is finished, the text box on the left side contains 

the full path of the file. 

Click the Simulated File button to open the Open out dialog window and select the 

“01_ss_dir_01.out” file. 

Click Open to start loading this file. The progress bar of the Open unstructured grid dialog shows 

the reading process. Close the Open unstructured grid dialog by clicking Close button to return to 

the main window. 

The main window now shows some geometric information about the loaded model (see Fig. 38). 
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Fig. 38 - TOUGH2Viewer main window that summarizes some geometric data of the loaded numerical model. 

In order to load shapefiles to be included in the 3D Model Frame, from the main menu select the File-

>Import shapefile menu item and the Import shapefile dialog window is opened (Fig. 39). 

 

 

Fig. 39 - Import shapefile dialog window. 

Click the add new ... button to open the LoadShapeFile dialog window (Fig. 40). 

 

 

Fig. 40 - Dialog window to load shape files. 
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Click the Shape File... button to display the Open dialog window and navigate to the base_ss folder. 

In particular, select the “base_ss.shp” file (Fig. 41). 

 

 

Fig. 41 - Dialog window to select the file to be loaded. 

To obtain a 2D preview of the base_ss.shp file, click Show Preview button of the Load Shape File 

box and the Shape file preview window is displayed (Fig. 42). 

 

 

Fig. 42 - 2D Preview of the base_ss.shp file 

Close the Shape file preview window by clicking the window icon . From the LoadShapeFile 

dialog window, select “Quota” item in the dbf field combo box (to load from a dbf file the elevation 

quote of the polylines object) (Fig. 43a) and click Import button (Fig. 43b). 
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(a) (b) 

Fig. 43a, b - LoadShpFile Dialog window 

 

The Import shapefile window now will be as shown in Fig. 44. The maximum number of loaded 

maps depends on the quantity of free RAM memory available.  

 

 

Fig. 44 - Import shapefile window. The table resume imported shape files. 

By double clicking the color bar near the file name, the Choose a color... window dialog window is 

displayed to change the color of polylines (Fig. 45). Choose a color to plot the curve of the shape map 

and click OK, then close the LoadShapeFile window by clicking the window icon  or the Close 

button. 
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Fig. 45 – “Choose a color …” dialog window window. 

Close the Import shapefile dialog window by clicking the window icon  or the Close button. 

6.3.2 3D Block model view 

From TOUGH2Viewer menu bar, click View -> 3D block model menu item and the 3D Block model 

dialog window display, as shown in Fig. 46. 

 

 

Fig. 46 - Top view of the 3D Block model. 

The isolines and surface representing the base_ss.shp loaded in the previous step is now merged in 

the model and can be showed. 

One can rotate, zoom, pan the model etc. using the mouse. To change variable to be showed, select it 

from Variable combo box. To change the time step, move the slide bar and automatically the plot 

will be update. 

From the Action combo box, select SetVOI. A SetVOI dialog window is displayed. In the panel 

Hide VOI, check the Enable checkbox, click both Default and Apply Hide VOI buttons (Fig. 47). 
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Fig. 47 - SetVOI dialog window. 

Close the SetVOI dialog by clicking the window icon  or the Close button.  

Is possible to rotate the view and minimize/enlarge the 3D frame by clicking the up black arrows 

(right-oriented arrow to minimize, left-oriented arrow to enlarge). The view of the model is now as 

shown in Fig. 48. 

To obtain block information, choose Action->QuickInfo, then click a block on the 3D frame. At the 

bottom of the dialog window, a set of information about the selected block will be displayed (Fig. 48, 

(a)). This information will be automatically update when another variable or time step is selected 

(Fig. 48, (b)). 

 

 (a) 

(b) 

Fig. 48 - (a) 3D model partially showed and block selected (white block); (b) information related to the selected block. 
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From the Action combo box, select FindBlocks and the Find Blocks dialog window is displayed 

(Fig. 49). From the combo box, select a specific block (by the TOUGH2 name) and automatically in 

the Block information panel some information about it are showed and in the 3D model frame it will 

be highlighted. 

To unselect the block, click unselect button. Close the Find Blocks dialog by clicking the window 

icon  or the Close button. 

 

 

Fig. 49 - Find Block dialog window. 

From the Action combo box, select SnapShot to display a SnapShot Preview dialog window that 

contains an image of the three-dimensional model (Fig. 50). With the File->Save as... menu item is 

possible to save the image (in png format) or send it directly to the printer by File->print menu item. 

Close the SnapShot dialog window by clicking the window icon  or via the File->Exit menu item. 

 

 

Fig. 50 - Snapshot Preview window dialog window. 

To repaint each block in material scale color (Fig. 51), from the Action combo box of the 3D Block 

model dialog window, execute the following commands: 

 ResetPositions; 

 FrontView; 

 SetVOI and in the setVOI dialog window uncheck Enable check box and close setVOI 

dialog window; 
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From Block Appearance of the 3D Block model dialog window, select RockType. 

 

 

Fig. 51 - 3D Block Model front view. Material color scale. 

From main menu, choose Tools-> Options, then click 3D Block model object tab to open the 

Options dialog window (Fig. 52). 

 

 

Fig. 52 – “Options” dialog window, “3D Block model object” tab. 

To obtain the view showed in Fig. 45, in the “Material” table of 3D Block model Object tab, uncheck 

the check box of column Visible for: 

ATMOS, CAPRO, SHAL1, SHAL2, VOLCA as show in Fig. 53. Only the materials SPIMP and 

SPLIQ are kept visible. 

 



TOUGH2Viewer Tutorial 40 

 

 

Fig. 53 - Options dialog “3D Block model object” tab, with modified parameters. 

To set not visible the contour line or the surface of shapefiles, uncheck the respective check box in 

the 3D Block model Object tab. Close the Options windows using the window icon , or the Close 

button. The 3D Block model view now will appear as showed in Fig. 54.  

 

 

Fig. 54 - 3D Block model.  

In the Options dialog window, 3D Block model Object tab, restore ATMOS, CAPRO, SHAL1, 

SHAL2, VOLCA again visible. 

In the 3D Block model, from the Action combo box select Get2DPlot command. Click a block in 

the 3D frame and a Profiles dialog window is displayed. 

From the time slider menu select the time step “6”. The graph will be update as shown in Fig. 55. 
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Fig. 55 - Profiles dialog which shows the pressure values along z axis. 

Close the Profiles dialog window by clicking the  windows icon or the Close button. 

In the Options dialog window, click on the Visualization Filter tab, select the T variable. In the min 

text box, type “270.0” and click the setNewValue button, and select the HideOutOfRange check 

box. In this way only blocks with temperature value between 270.0 and 291.01 °C are visible, note 

that also the colour scale, on the right frame, has changed as shown in Fig. 56. 

In the 3D Block model window, select T from Variable combo box and move the time slider at 

position “6-th” (last time step present in this simulation output file).  

 

 

Fig. 56 - Bottom filtered view of the 3D model with modified color scale. 

Close the 3D block Model by clicking the  windows icon or the Close button. 

6.3.3 3D Flow Vector visualization 

This functionality gives a 3D vector representation of the heat or mass exchange among blocks. Select 

the View->3D Flow Vector menu item. A 3D Flow Vector window opens, showing the default 

variable FHEAT, as shown in Fig. 57. 
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Fig. 57 - 3D Flow vector default view. 

From the Variable combo box, select Vel(GAS) item and move the time slider to 1. With the usual 

CAD command zoom and rotate the model in the desiderated position (Fig. 58). 

 

 

Fig. 58 - 3D Flow model at the time step 1 for the variable VEL(GAS). 

Close the Flow profile window by clicking the  windows icon or the Close button. 

Close the 3D Flow vector window by clicking the  windows icon or the Close button. 

6.3.4 3D Iso Surface 

Select the View->3D Iso Surface menu item. 

Open a 3D Iso Surface dialog (Fig. 59) and from the Variable combo box, select T (default is P). 

Leave other parameters as default and click Plot iso surface button. Wait few seconds to complete 

the interpolation process, and then a new IsoSurface window opens to plot the selected variable. 
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Fig. 59 - 3D IsoSurface dialog window. 

In this window, move the first continuous slider to 270 °C. The plot windows will appear as shown 

in Fig 52. To see the evolution of isosurface over time steps, move the time slider located under 

continuous slider. Click the Properties button to change colour background, to switch from parallel 

to perspective view, to change axis colour or to hide the thin box. 

 

 

Fig. 60 - Isosurface for T=270°C, time step “6”. 

Close the IsoSurface for T … and the 3D Isosurface window by clicking the  windows icon or 

the Close button. 

6.3.5 2D Contour map 

Select the View->2D Contour map menu item and a 2D Contour plot window will open.  

In the 2D Contour plot window, set the Sectioning plane combo box to XZ, and type “4745000” 

(vertical XZ section at y=4745000 m), move the time slider at position “6-th” (last time step present 

in this simulation output file) and click the Plot button. A Contour Plot window will be displayed as 

shown in Fig. 61. 
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Fig. 61 – Temperature isolines contour map. 

After having adjusted the parameter of plotting, click the Plot button to update the graph. 

Close the 2D Contour plot window by clicking the  windows icon or the Close button. 

6.3.6 Statistics 

Click the Analysis-> Statistics menu item and then Statistics dialog window opens. See paragraph 

6.1.5 for details about Statistics dialog. 

Exit form TOUGH2Viewer by clicking the window icon  or by File->Exit menu item. 
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6.4 Voronoi 3D grid model 

This example is related to a Voronoi 3D unstructured grid model, built using VORO2MESH (Bonduà 

et al., 2017) to create full Voronoi 3D grid. This grid is also a Central Voronoi Tessellation (CVT). 

The example folder “\T2Viewer\ExampleData\04_voronoi_3D\”contains the following files: 

 

o MESH: the classical TOUGH MESH 

o tough2viewer.dat: the geometry file, as generated by VORO2MESH; 

o voronoi3D.out: the simulation output results of TOUGH simulation run. 

 

Start TOUGH2Viewer (Windows OS) by double clicking the batch file go.bat then the main window 

of TOUGH2Viewer is displayed, as shown in Fig. 62. 

 

 

Fig. 62 - TOUGH2Viewer empty main window. 

6.4.1 Load Files 

From main menu, click the File->Open unstructured V++ grid menu item.  

The Open unstructured V++ grid dialog window will be displayed (Fig. 63). 

 

 

Fig. 63 – Input unstructured grid window 
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Click the File button to open the tough2viewer.dat dialog window and select the file called 

“tough2viewer.dat” from the working folder. 

Click Open to start reading this file. Once finished is possible to visualize a preview by clicking the 

3DPreview button on the right. 

Click the MESH File button to open the Open MESH dialog window and select the “MESH” file in 

the same folder. 

Click Open to start loading this file. Click the Simulated File button to open the Open out dialog 

window and select the “voronoi.out” file. 

Click Open to start loading this file. The progress bar of the Open unstructured V++ grid dialog 

shows the reading process. Close the Open unstructured V++ grid dialog by clicking Close button 

to return to the main window. 

The main window now shows some geometric information about the loaded model (see Fig. 38). 

 

 

Fig. 64 – The main window 

6.4.2 3D Block model view 

From TOUGH2Viewer menu bar, click View -> 3D block model menu item and the 3D Block model 

dialog window display, as shown in Fig. 65. 

 

 

Fig. 65 - Top view of the 3D Block model. 

Move the variable combo box to SG (Saturation of Gas). Rotate and change the time step 

progressively. 

Visualization can appear as follow in Fig. 66. 
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Fig. 66 – View of the SG thermodynamic variables (3D Block model). 

Explore the model with the command as explained in the previous chapters. 

6.4.3 Prepare GENER file 

In this paragraph, by using TOUGH2Viewer is possible to select the blocks that will be used as 

GENER blocks int TOUGH simulations.  

From the Action dropdown menu select the MultipleSelection Command. 

As shown in Fig. 67, select two top opposite blocks of the grid by clicking on it. 

 

 

Fig. 67 – MultipleSelection command: a set of blocks that can be selected for further editing or exporting 

Select from the Action dropdown menu the AdvanceBlockSelection, and then click on the button 

Open modify Selection… 
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Fig. 68 – Properties modifier dialog window. With the current block selection, is possible to assign an existing rocktype 

(button rocktype) or to create and assign a new rocktype (button New RockType). 

The properties modifier dialog window will shown (Fig. 68). Click on ExportThisSelection and 

choose a filename, for example “generblocks”. An ASCII file will be created as shown in Fig. 69. 

 

 

 

Fig. 69 – The generated ASCII file 

Remove all unwanted information and create your GENER file by using a text editor (Fig. 70). 

 

 

Fig. 70 – The modified GENER file 

INCON generation 

Before creating an INCON file, is necessary to load a previous INCON or SAVE file as created, for 

example, by VORO2MESH or by a dummy run of TOUGH. 

Load the INCON from file by the Open Unstructured V++ grid… dialog window. 

Press the Generate INCON button. A new dialog window will be shown. From the variable selector 

select INCON_0 and then press the add button. Repeat the previous step up to the INCON_3 variable. 

Select from the INCON VARIABLES selector the INCON_0 variable and update the plot by pressing 

UpdatePlot. The Dialog will now have the aspect of Fig. 71. 
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Fig. 71 – INCON generator dialog window. 

Set your value of INCON_0 (Pressure in this example) as 3.0E6 Pa and click on Preview button. In 

The new graph will be updated as shown in Fig. 72. Click on the Apply button to apply the changes. 
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Fig. 72 – INCON generator dialog window preview. 

 

Click on Apply. Repeat all steps for the other INCON variables. When finished, move to the Write 

Out tab, and click on update preview, as shown in Fig. 73. 
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Fig. 73 – INCON generator dialog window –write out tab preview 

To export the INCON data press on the Choose File to save as… and insert the output filename. 

6.4.4 Export data to Paraview 

To export the model in a file format readable using Paraview, from the main menu, click the File-

>Open unstructured V++ grid menu item.  

The Open unstructured V++ grid dialog window will be displayed (Fig. 63). Click the command 

button Export2VTU. A set of files (one for each time step) will be written in the same folder where 

data was read, named “out_[time_step_counter].vtu”. Open these files with Paraview to inspect 

simulation results. 
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6.5 The Amiata structured 3D grid case 

In this example will be show how to handle material assignation of a pre-existing numerical “empty 

model” using raster surface. 

In the folder “\ExampleData\ 05_Amiata3D\Structured_3D” you will find the following files: 

01dem.dat  

01dem.dat.ply  

02fractured.dat  

02fractured.dat.ply  

03caprock_shal.dat 

03caprock_shal.dat.ply 

04shallow_res.dat  

04shallow_res.dat.ply  

05caprock_deep.dat 

05caprock_deep.dat.ply 

06bottom-5000.dat  

06bottom-5000.dat.ply  

voro.par 

MESH 

tough2viewer.dat 

 

Each file represents the top surface of a different geological layer. In this example we just focus our 

attention on the rocktype assignation, without considering petrophysical properties of the geological 

layer, to be treated separately in the ROCKTYPE section of the TOUGH2 input file. 

The coordinates of the surface and of the model are referred to geographical coordinates. 

The limit of the domain of the numerical model are (m): 

x_max=1726500.00 

x_min=1701500.00 

y_max=4759500.00 

y_min=4732500.00 

z_max=2000.00 

z_min=-6000.00 

The empty model builded using VORO2MESH, is composed by: 

 

x_max x_min y_max y_min z_max z_min 

1726500 1701500 4759500 4732500 2000 -6000 

Lx= 25000 Ly= 27000 Lz= 8000 

nx 25 ny 27 nz 40 

Tot. Blocks 27000     

Block dimensions     

dx= 1000 dy= 1000 dz= 200 

Table 1 – Domain bound and grid information 

 

We are using a finer discretization in the vertical direction. 

The dimensions of the blocks are: 1000x1000x200 m3. 

Open TOUGH2Viewer and from the menu “file” select “Open unstructured V++ grid…” and then 

select the tough2viewer.dat file and the MESH file from the example folder. Close the dialog by 

selecting the close button. 

From the menu “file” select “Import Surface File…” and then select, in the following order, the files: 
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 01dem.dat  

 02fractured.dat  

 03caprock_shal.dat 

 04shallow_res.dat  

 05caprock_deep.dat 

 06bottom-5000.dat 

After surfaces importation procedure finishes, the Import Shapefile dialog window will be as 

shown in Fig. 74. 

 

 

Fig. 74 – ImportShapeFile window after surface file importing. 

 

Optionally, user can modify the aspect ratio of the model and of the surface shape by selecting from 

the menu Options->3D Block model object a Z Stretch Factor=5, then click apply (Fig. 75). 
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Fig. 75 – Options dialog window, 3D Block model tab. 

From the View menu, select View->3D Block model. The starting view is the top view. 

Rotate the model and obtain the representation as shown in Fig. 76 
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Fig. 76 – The empty 3D structured model and the surfaces. 

 

Select from the Action dropdown menu the AdvancedBlockSelection command. 

From the AdvancedBlockSelection dialog window (Fig. 77), select above and 01dem.dat surface 

selection. Press Add. 
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Fig. 77 – Advanced Block Selection dialog window 

All the blocks that have the coordinates block node above the selected surface will be selected. 

Press the Open Modify Selection… button.  

On the Properties modifier dialog window (Fig. 78) insert using the New Rocktype text box a new 

rocktype name “ATMO1”. Then click Apply. 

 

 

Fig. 78 – properties modifier dialog window 
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Close the Properties modifier dialog window. In the AdvancedBlockSelection dialog window press 

ResetSelection and confirm. 

  

The model rocktypes has then been modified as shown in Fig. 79. 

 

Fig. 79 – The modified model after rocktype assignation 

 

Select now the Inside dropdown menu block selector from the AdvancedBlockSelection dialog 

window, panel “surface selector” and select as first surface 01dem.dat and as the second surface the 

02fractured.dat record. Note that the selected blocks are hidden from the ATMO1 type blocks. Open 

the Options dialog window and hide the ATMO1 blocks type and, optionally, the 01dem.dat surface. 

Open the Properties modifier dialog window and assign the material VULC2. 

By repeating these steps, assign the materials types to each strata, up to have a material type 

assignation like: 
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Fig. 80 – The final 3D structured model with the desired rocktype assignation. 

 

 

Fig. 81 – The Option dialog window. Note the new rocktypes created during the model modifications. 

User may also set the boundary condition for ATMO1 blocks type. This operation can be perfomed 

by selecting the ATMO1 block type using the AdvancedBlockSelection dialog window and then 
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using the properties modifier by pressing the Volume apply button. This action will modify the 

volume of the selected block to an infinite volume (or to a volume set by the user). 

Open the Properties modifier dialog window and press ExportTheModifiedGrid button. In the 

Save File dialog window choose a name for the new grid, e.g. model01, and click the Save button. 

In the selected folder a new MESH and tough2viewer.dat file, named model01.dat and 

model01_tough2viewer.dat respectively has been created. 

User can open the new generated model again by TOUGH2Viewer in another session for grid 

inspection before running a TOUGH2 simulation. 

Note that: 

The strata SHAL1 have some pinch-out because the distance between the 2 surfaces was near to zero 

and there are not blocks with the node included in these two surfaces. 
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6.6 The structured grid case 

In this example will be show how to handle material assignation of a pre-existing numerical “empty 

model” using a set of raster surfaces. 

In the folder “\\ExampleData\ 06_Structured2D” you will find the following sub-folders: 

 

 model; 

 surfaces; 

 voro2mesh; 

 

The voro2mesh folder contains all the input data needed for the generation of the empty model, using 

VORO2MESH. For details about VORO2MESH, please see Bonduà et al. (2017). 

In the model folder, you will find the MESH file and the tough2viewer.dat file (geometrical data) as 

generated by VORO2MESH. 

The surfaces folder contains the surfaces files that will be used for rocktype assignation, in raster and 

in ply file format: 

 

 00top.dat; 

 00top.ply; 

 01top.dat; 

 01top.ply; 

 02top.dat; 

 02top.ply; 

 03top.dat; 

 03top.ply; 

 

A graphical representation of these surfaces is given in Fig. 82. 

 

Fig. 82 – The four surfaces used to define the several geological horizons. Image obtained with Paraview. 
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Each file represents the top surface of a different geological layer. In this presentation we just focus 

the attention on the rocktype assignation, without considering petrophysical properties of the 

geological layer, to be treated separately in the ROCKTYPE section of the TOUGH2 input file. 

The limits of the domain of the numerical model are (m): 

 

x_max=+5000.0 

x_min=0.0 

y_max=+1000.0 

y_min=0.0 

z_max=500.0 

z_min=-3000.0 

 

The dimension of the blocks are: 100x1000x100 m3. 

Open TOUGH2Viewer and from the File menu select Open unstructured V++ grid…  

Select the tough2viewer.dat file and the MESH file from the path: 

\\ExampleData\06_Structured2D\model. 

Press the CreateEmptyModel button and then close the dialog by selecting the Close button. 

From the File menu select Import Surface File… 

Select the files in the following order: 

 

 00top.dat; 

 01top.dat; 

 02top.dat; 

 03top.dat; 

 

 

Fig. 83 – The ImportShapefile dialog window after data loading. 

From the TOUGH2Viewer View menu, select View->3D Block model. From the dropdown 

BlockAppearance, select the Rocktype item.  The initial view is the top view. 

Rotate the model and obtain the representation as shown in Fig. 84. 

 

file://///ExampleData/06_Structured2D/model
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Fig. 84 – The model and the surfaces visualized in the Model3D window. 

From the Action menu, select the AdvanceBlockSelection command. The AdvanceBlockSelection 

dialog window of Fig. 85 will be shown. 

 

 

Fig. 85 – The AdvanceBlockSelection dialog window. 

From the Surface Selector panel, press the add button that belong to “Select blocks that are above the 

surface 00top.dat” line. 
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With this command all blocks that are above the surface 00top.dat will be selected. Press now the 

Open Modify selection… button. In the dialog window, enter a new rock type called ATMO1. Then 

press Apply (see Fig. 86). 

 

 

Fig. 86 – properties modifier dialog window. 

 

Close the window and in the AdvancedBlockSelection press the ResetSelection button. 

The model will now appear as shown in Fig. 87. 

In the Surface Selector panel of the AdvancedBlockSelection dialog window, press the add button 

relatively to the command “Select blocks that are inside the surface 00top.dat and the surface 

01top,dat”. By the Open Modify Selection command, assign to the selected blocks a new rocktype 

CAPR2.  

The model is now modified as shown in Fig. 89. 

By repeating the above procedure by changing the surfaces, a final model can be obtained. 

A view of the final model is shown in Fig. 90. 

 

 

Fig. 87 – The modified grid. 
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Fig. 88 – The block selection between two surfaces. 

 

Fig. 89 – The modified grid. 
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Fig. 90 – The final grid. 

User can change the rocktype color by the Tool->Option dialog window. In the Fig. 91 is shown the 

same model of Fig. 90 with the color of rocktypes changed and the surfaces colored by rocktype. 

Also a setVOI command is applied to the visualization. 

 

 

 

Fig. 91 – The final model with modified colors and VOI applied. 

After rocktype assignation and/or blocks volume editing, the modified model must be saved by using 

the ExportTheModfiedGrid command of the PropertiesModifer dialog window. In Fig. 92 is 

shown the save dialog window after pressing the ExportTheModifiedGrid button. Note that in the 

same folder will be saved also a copy of the tough2viewer.dat, because in case of a generation of a 

sub grid, a different geometry file is needed. 
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Fig. 92 – The modified grid is saved as “modified_grid”. 

INCON generation 

Before creating a new INCON file, a previous INCON or SAVE file must be loaded. 

Load the INCON.dat file by the Open Unstructured V++ grid… dialog window. 

In the AdvancedBlockSelection dialog window, press the Generate INCON button or, alternatively, 

from the TOUGH2Viewer main menu select Tools->Create INCON. The INCON Generator dialog 

window will be shown. From the variable selector select INCON_0 and then press the add button. 

Repeat the previous step up to the INCON_3 variable. Select from the INCON VARIABLES 

selector the INCON_0 variable and update the plot by pressing the UpdatePlot button. The INCON 

Generator dialog will now have the aspect of Fig. 93. 

  



TOUGH2Viewer Tutorial 67 

 

 

Fig. 93 – The INCON generator dialog window 

Select the basic tab. This tab allows one to build/edit the INCON variable by means of a linear 

function. Press the P button (Pressure) to load default parameter for hydrostatic condition. Press the 

zero to top button to modify the equation in a manner that the top blocks have the pressure of the 

Zero text field (by default, atmospheric pressure for the top blocks). Press the Preview button to 

visualize the new INCON before applying changes. The INCON Generator dialog window appear 

now as shown in Fig. 94. 
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Fig. 94 – The INCON generator dialog window with a preview of the linear function. 

After pressing the Apply and Preview buttons again, the variable are modified as shown Fig. 95. 

Repeat the previous steps for INCON_1 (temperature), INCON_2 (XCO2) and INCON_3 (XNACL). 

It worth to mention that the tool allows one to apply the changes to all the blocks, to the blocks of a 

certain rocktype or just to the selected blocks. 

Once that the INCON has been modified, user can visualize the new values in to the Model3D 

visualization window by choosing the variable to be visualized by selecting the variable to plot. To 

save the edited INCON file, a write out tab is designed to obtain the formatted INCON file as required 

by TOUGH. Press the write out tab and the preview button. The dialog window now displays a 

preview of the INCON file (see Fig. 96). Note that the numbering format can be changed by the user 

if the particular EOS used for the numerical simulation require a special format. 
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Fig. 95 – The INCON generator dialog window after changes are applied. 

 

 

Fig. 96 – The INCON generator preview dialog window. 
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As last step, press the Choose File to save as… button to generate the new INCON file. The created 

file will be [inserted name file].INCON. 

The generated files (the MESH and the INCON file) are now ready to be used in a TOUGH 

simulation.  

It worth mentioning that the number of primary variables written in to the INCON file have to match 

with the number of variables required by the specific EOS - TOUGH simulator and option, and no-

check or validation will be performed on it by TOUGH2Viewer. 
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